Mikrotik hints

NAT vnitřních sítí na různé veřejné IP na jednom rozhraní

Pokud mám dvě a více veřejných IP adres na jednom rozhraní (např. eth1) a chci vnitřní sítě (více subnetů) mapovat na různé veřejné IP, nesmí se použít maškaráda. Ta totiž dělá to, že pro daný subnet zvolí veřejnou IP automaticky, čili ve většině případů první nejnižší IP. Místo toho je dobré použít action=src-nat v kominaci s to-addresses, čímž se definuje na jakou jednu konkrétní IP chci subnet mapovat.

Konkrétně tedy

/ip firewall nat
add chain=srcnat src-address=192.168.1.0/24 action=src-nat to-addresses=1.1.1.1 out-interface=Public
add chain=srcnat src-address=192.168.2.0/24 action=src-nat to-addresses=1.1.1.2 out-interface=Public

Napsat komentář

Vaše emailová adresa nebude zveřejněna. Vyžadované informace jsou označeny *